-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathsumOfoddEven.cpp
56 lines (54 loc) · 1.28 KB
/
sumOfoddEven.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
/*Problem statement
Write a program to input an integer 'n' and print the sum of all its even digits and the sum of all its odd digits separately.
Digits mean numbers, not places! That is, if the given integer is "132456", even digits are 2, 4, and 6, and odd digits are 1, 3, and 5.
Constraints
0<= 'n' <=10000
Example :
Input: 'n' = 132456
Output: 12 9
Explanation:
The sum of even digits = 2 + 4 + 6 = 12
The sum of odd digits = 1 + 3 + 5 = 9
Constraints
0<= 'n' <=10000
Example :
Input: 'n' = 132456
Output: 12 9
Explanation:
The sum of even digits = 2 + 4 + 6 = 12
The sum of odd digits = 1 + 3 + 5 = 9
Input format :
The first line contains an integer 'n'.
Output format :
In a single line, print two space-separated integers, first the sum of even digits and then the sum of odd digits.
Sample Input 1:
132456
Sample Output 1:
12 9
Explanation of sample input 1 :
The sum of even digits = 2 + 4 + 6 = 12
The sum of odd digits = 1 + 3 + 5 = 9
Sample Input 2:
552245
Sample Output 2:
8 15
*/
#include<iostream>
using namespace std;
int main(){
int n;
cin>>n;
int odd=0,even=0;
while(n>0){
int digit=n%10;
if(digit%2==0){
even+=digit;
}
else{
odd+=digit;
}
n=n/10;
}
cout<<even<<" "<<odd;
return 0;
}