-
Notifications
You must be signed in to change notification settings - Fork 1
/
SumOfSeriesLoops.java
88 lines (55 loc) · 1.6 KB
/
SumOfSeriesLoops.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
/*
We use the integers , , and
to create the following series:
You are given
queries in the form of , , and . For each query, print the series corresponding to the given , , and values as a single line of
space-separated integers.
Input Format
The first line contains an integer,
, denoting the number of queries.
Each line of the subsequent lines contains three space-separated integers describing the respective , , and
values for that query.
Constraints
Output Format
For each query, print the corresponding series on a new line. Each series must be printed in order as a single line of
space-separated integers.
Sample Input
2
0 2 10
5 3 5
Sample Output
2 6 14 30 62 126 254 510 1022 2046
8 14 26 50 98
Explanation
We have two queries:
We use
, , and to produce some series
:
... and so on.
Once we hit
, we print the first ten terms as a single line of space-separated integers.
We use
, , and to produce some series
:
We then print each element of our series as a single line of space-separated values.
*/
import java.util.*;
import java.io.*;
class Solution{
public static void main(String []argh){
Scanner in = new Scanner(System.in);
int t=in.nextInt();
for(int i=0;i<t;i++){
int a = in.nextInt();
int b = in.nextInt();
int n = in.nextInt();
int sum=a+b;
for(int j=1;j<=n;j++){
System.out.print(sum+" ");
sum=sum+(int)Math.pow(2,j)*b;
}
System.out.println();
}
in.close();
}
}