-
Notifications
You must be signed in to change notification settings - Fork 1
/
Copy pathPatternSyntaxChecker.java
58 lines (41 loc) · 1.35 KB
/
PatternSyntaxChecker.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
/*
Using Regex, we can easily match or search for patterns in a text. Before searching for a pattern, we have to specify one using some well-defined syntax.
In this problem, you are given a pattern. You have to check whether the syntax of the given pattern is valid.
Note: In this problem, a regex is only valid if you can compile it using the Pattern.compile method.
Input Format
The first line of input contains an integer
, denoting the number of test cases. The next
lines contain a string of any printable characters representing the pattern of a regex.
Output Format
For each test case, print Valid if the syntax of the given pattern is correct. Otherwise, print Invalid. Do not print the quotes.
Sample Input
3
([A-Z])(.+)
[AZ[a-z](a-z)
batcatpat(nat
Sample Output
Valid
Invalid
Invalid
*/
import java.util.Scanner;
import java.util.regex.*;
public class Solution
{
public static void main(String[] args){
Scanner in = new Scanner(System.in);
int testCases = Integer.parseInt(in.nextLine());
while(testCases>0){
String pattern = in.nextLine();
//Write your code
try{
Pattern.compile(pattern);
System.out.println("Valid");
}
catch(PatternSyntaxException e){
System.out.println("Invalid");
}
testCases--;
}
}
}