-
Notifications
You must be signed in to change notification settings - Fork 1
/
JavaOutputFormatting.java
60 lines (44 loc) · 2.01 KB
/
JavaOutputFormatting.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
/* Java's System.out.printf function can be used to print formatted output. The purpose of this exercise is to test your understanding of formatting output using printf.
To get you started, a portion of the solution is provided for you in the editor; you must format and print the input to complete the solution.
Input Format
Every line of input will contain a String followed by an integer.
Each String will have a maximum of
alphabetic characters, and each integer will be in the inclusive range from to
.
Output Format
In each line of output there should be two columns:
The first column contains the String and is left justified using exactly
characters.
The second column contains the integer, expressed in exactly
digits; if the original input has less than three digits, you must pad your output's leading digits with zeroes.
Sample Input
java 100
cpp 65
python 50
Sample Output
================================
java 100
cpp 065
python 050
================================
Explanation
Each String is left-justified with trailing whitespace through the first
characters. The leading digit of the integer is the character, and each integer that was less than digits now has leading zeroes.
*/
import java.util.Scanner;
public class Solution {
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
System.out.println("================================");
for(int i=0;i<3;i++){
String s1=sc.next();
int x=sc.nextInt();
//Complete this line
// System.out.printf("%-15s%03d%n",s1,x);
System.out.printf("%-15s%03d%n",s1,x);
//% -->formatter 15 -->padding width including string length and 0 -->adding with int 3 -->length of int - --> right padding after string + -->for left padding before string n--> new line
//System.out.printf(format, arguments);.
}
System.out.println("================================");
}
}